British Columbia Aquarium Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2,267 Posts
Discussion Starter · #1 · (Edited)
72" Hamilton Technology Deluxe Metal Halide Fixture - 3 x so i have a corallife like this . the plug in was wet and fried so is this hooped our can this electrical be fixed. and its not the three metal halide its the to marine glow 48 inche tubes . can this be fixed
help help help
if it can be fixed how much
got wet from the rain when i brought the tank home
 

·
Registered
Joined
·
2,838 Posts
So what im hearing is you fried your fixture, it got wet, you plugged it in and it made a bad smell. Your metal hallide's work fine, but its the VHO flourescents that do not work. Sounds to me like a fried ballast.... But verify the bulbs first if possible. Make sure you know your exact model, and go here:

http://www.hamiltontechnology.com/shop/index.php?task=show&cat=Fluorescent+Replacement+Ballast

I do not recommend getting anything else but the manufacturers ballast because you risk doing more damage to other parts. Ballasts differ, especially heat dissapation wise. I may not be much involved tech wise in the hobby, but i am an electrician and lighting plays a significant role in my carreer.
 

·
Registered
Joined
·
2,267 Posts
Discussion Starter · #3 · (Edited)
what about the plug ins they made a noise what if i change those.
can any one come look our help me . figure out what i did and maybe see if it can be fixed
 

·
Premium Member
Joined
·
453 Posts
Not sure what you mean exactly by a "plug in" but it sure sounds like a ballast issue. Some pictures could help.
 
1 - 6 of 6 Posts
Top