British Columbia Aquarium Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
8,717 Posts
Discussion Starter · #1 · (Edited)
Am I a dunce? I wanted a maxijet, but when I got to King Ed's they didn't have any of the smaller ones and I didn't want a 1200, so I got the AC70. Anyway, they convinced me to get the filter attachment to prevent little fishes from getting sucked in (mostly my Cories). I'm forever cleaning that thing, which is a bit annoying, but the most annoying thing is that the venturi feature doesn't appear to work properly. It works only for a day after I clean it out. Does it only work under extremely high flow rates? Should I remove the filter attachment? Should I sell it and get another maxijet?
 

·
Registered
Joined
·
463 Posts
Hi Garry......are you looking for a power head or HOB?......I hate using the Aquaclear 70 sooo hard to restart after doing water changes
 

·
Registered
Joined
·
8,717 Posts
Discussion Starter · #3 ·
Hi Garry......are you looking for a power head or HOB?......I hate using the Aquaclear 70 sooo hard to restart after doing water changes
Sorry, typing too fast. It's the powerhead. Mine restarts no problem. I forget to mention that I run it only when the lights are out to increase air exchange for my plecos. But without the venturi effect, it's just moving the water below the surface and not at the surface (I'm using the clip attachment).
 

·
Registered
Joined
·
916 Posts
is it this one ?
Aqua Clear 70 Power Head (Old 802) (Hagen)

The flow rate would make a big difference in the venturis ability to draw air no doubt. Can you put a larger prefilter on ,to give more flow as it plugs up ?.Or if its the black 4 piece snap together pre filter..like this,
Hagen AquaClear Filters: Hagen AquaClear Quick Filter Power Head Attachment at PETdiscounters.com

just wrap the tube with filter material and scrap the fine pads.

Just reread the thread .....can you not turn the flap up to get the water to break the surface?
 

·
Registered
Joined
·
8,717 Posts
Discussion Starter · #5 ·
Yep, that's the one, and yes that's the filter attachment. I didn't think the flow rate would be so drastically affected. It essentially no longer works after one day and I have max flow rate set.

And as for the flap, mine didn't come with one, I don't think (have to go home and check the box). I think the 802 had one, but when it became the 70 it didn't have one anymore (at least it doesn't show it on the box) Hagen Aquaclear 802/70 Powerhead

I was thinking of not running any filtration material at all and pulling the filtration cartridge, but was afraid of sucking up fish (is that possible even)?
 

·
Registered
Joined
·
916 Posts
The fine pads in the pre filter are pretty fine thus they clog fast. Just remove the stock filter sock and wrap inner tube with filtering pad.
I have a wack of directional valves n such that may be adaptable to your outlet to create more surface water movment. ( more than welcome to come look ) you could put a short piece of hose on with an upward twist maybe ?

edit edit ...
sucking up fish ? well depends how big they aren't ;)
I am pretty sure I have a piece that would fit on the thing ...if you want to bring it by your more than welcome to .... no charge of course :)
 

·
Registered
Joined
·
8,717 Posts
Discussion Starter · #7 ·
Ok, thanks. I'll try remove the sleeve first and see if it helps. If it does I'll just leave things alone. Or I might mod small prefilter with a sponge as this thing is horrendously ugly in my tank. If that doesn't do what I want I might hit you up for a valve, but I'll try the simple fix first.
 

·
Registered
Joined
·
916 Posts
Ok, thanks. I'll try remove the sleeve first and see if it helps. If it does I'll just leave things alone. Or I might mod small prefilter with a sponge as this thing is horrendously ugly in my tank. If that doesn't do what I want I might hit you up for a valve, but I'll try the simple fix first.
if it turns out you dont use it let me know .I will buy it from you as I could use another one.....just sayin :)
 
1 - 9 of 9 Posts
Top