British Columbia Aquariums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
742 Posts
Discussion Starter #1 (Edited)
Have a Eheim 2215 filter. Everything works great, a little noisy though. Comes with sponge only. Regular intake and spraybar.

It's either rattling or there's still air in it.

There are times its dead silent (and working!!) and theres times where it is noisy (sounds like rattling) but goes back to being silent after a while. When it's noisy, it's usually after I service it.

Selling it because I just shut down one of my tanks.

Missing items:
- rubber feet on the bottom
- efisubstrat (bio-filter media)

Same as this one
http://www.petsandponds.com/en/aquarium-supplies/c5809/c7359/p16366949.html

Selling for $60
 

·
Registered
Joined
·
742 Posts
Discussion Starter #3 (Edited)
It's either rattling or there's still air in it.

There are times its dead silent (and working!!) and theres times where it is noisy (sounds like rattling) but goes back to being silent after a while. When it's noisy, it's usually after I service it.

Selling it because I just shut down one of my tanks.
 

·
Registered
Joined
·
742 Posts
Discussion Starter #4
price reduced!


Just to make things clear, the filter WORKS. It's just noisy right after its been serviced and returns to being quiet after some time.
 

·
Registered
Joined
·
742 Posts
Discussion Starter #6
I think it might be the design of it. When I had a 2213 and my other 2215 both make noise when I service it. I think its because I don't turn it off properly before I service it.
 

·
Registered
Joined
·
2,888 Posts
WOW $60? That's a steal!!! I'd take it off your hands if I could drive right now... god I hate injuries!
 

·
Registered
Joined
·
742 Posts
Discussion Starter #9
Nothing wrong with the design. All the new ones are all silent. When it gets worn, the impeller will make noise until gunk builds up on it and buffers the sides.
What I mean is air gets into it becuase I turn it off first and then close the connectors. When air gets in it, the impeller makes a ton of noise. I think its a design flaw because the classics don't purge air like the pro models or rena filters. It's also a lot harder to prime the filter compared to the pro model or rena filters.

The impeller is very clean and is pretty new.
 

·
Registered
Joined
·
8,717 Posts
Are you filling the canisters after you service them? If so, don't. If you left them empty and open the taps, the canister fills to the top and purges all the air. Every time I try to be smart and fill the canister I get an airlock. I've experimented with this a lot with my 2213 and it happens every single time.
 
1 - 10 of 10 Posts
Top