British Columbia Aquarium Forums banner

1 - 5 of 5 Posts

·
Super Moderator
Joined
·
4,021 Posts
Discussion Starter · #1 ·
Anyone else having trouble with google chrome, I have been using it for the last year trouble free. Now for whatever reason it randomly come up with "google chrome not responding" message and freezes up. Now because it has frozen up I I have to do force shutdown and restart, then it says in a box in the top right hand corner Google chrome was not shutdown properly "Ya I know that" with a tab that you have to click on to make it work again. What a PITA, then I try and go to google help and it's like trying to fly the space shuttle for the first time. I know how to use programs and get around on a computer but using google help is very confusing and not user friendly IMO. Can anyone offer any help with this, I'm just not techie enough I guess. :(
 

·
Registered
Joined
·
294 Posts
If you use a gmail account and have it synced, just uninstall it and re-install.
 

·
Super Moderator
Joined
·
4,021 Posts
Discussion Starter · #3 ·
If you use a gmail account and have it synced, just uninstall it and re-install.
I use Shaw mail and have for over a year with no problems. I'm wondering if my computer is getting tired and is having trouble keeping up sometimes, bought it 2010, so it's 7 years old. Thoughts anyone!
 

·
Registered
Joined
·
415 Posts
if it does not happen too often, then the problem is rather common. Common in at least you and I share it. Last time I formatted my computer it kinda just got grumpy at me. Every now and again it will lock up like an outboard left to winter in the water. My computer is about new so I wouldn't attribute it to age. The most helpful thing you can do is to uninstal the program complete. Reinstall and hope for the best. I am too lazy to even do that so I just tolerate it.

If you need a hand on the run down of how to do it let me know. Good luck.

The best thing to remember with electronics is "...sometimes there is no good reason"
 

·
Registered
Joined
·
334 Posts
I've been having issues with Chrome, Google Classroom and even accessing google.ca using Safari with weird security requests (the I Am Not A Robot test) as well as general connection issues over the past few weeks. No idea on which end the problems are originating, but I've spent the last couple of days fiddling with firewall security settings and chrome admin. Still not sure what's going on. I am not an expert by any stretch and would love to hear if anyone knows what the problem is. Am quite relieved I am not the only one.
 
1 - 5 of 5 Posts
Top