British Columbia Aquarium Forums banner
1 - 11 of 11 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
HI, hoping to get some help.
I moved a year ago and since then my plants are severely stunted. I only moved across town and have a second tank where i don't have this issue.
I was using 2 green leaf led strips, pressurized co2, Eco complete substrate and dose micro and macro nutrients.
I am just at my with end as I have also recently added another marineland plant led strip and been doubling my dosing and increased the co2 output.
The plants will bubble and there is some pearling in the tank but still none of the plants grow more than 3 inches.
I have jungle val, swords, apponagetton..... All pretty low demand plants but still no luck. Any help would be super appreciated.
 

· Premium Member
Joined
·
5,688 Posts
All 3 of the plants you mentioned are heavy root feeders and don't need a lot of light or CO2 to thrive. Is the Eco-complete well used? If so you may not be providing enough root fertilization and may want to dial back the lighting, CO2, and may want to use something like Flourish root tabs or similar product and you should get better results.

JM2C.

Stuart


Tankless in Vancouver
 

· Registered
Joined
·
3,251 Posts
What is your water hardness, specifically GH?
 

· Registered
Joined
·
3,251 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
So even with extra dosing and increasing hardness they is new growth but still stunted, badly.
Here are a couple pick of my disaster. The larger sword was added a week or 2 ago and you can clearly see its not doing well
 

Attachments

1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top