British Columbia Aquarium Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Just need some advice from people who have been at this longer. I purchased a bristlenose at PetSmart ( my first mistake) and the next week noticed it plus my 2 lemon tetras were just covered in white spot. Oddly enough my krib showed no sign of being sick. Started treatment and 4 days later....both tetras were dead. Today, I found the bristlenose dead. The krib still is not showing signs of being sick except for laying on the bottom of a rock. I don't think he's going to last much longer, though he doesn't have any spots on him.

Question, after he dies ( I think it's inevitable) how do I make sure the whitspot is gone before adding new fish. Also, how long will the bacteria in the filter last if there are no fish in the tank. Ugh I know I shouldn't have bought a fish at PetSmart but he was sooo cute!
 

·
Registered
Joined
·
349 Posts
Which treatment did you run? As well as, how long has your tank been set up and was it fully cycled? Do you test the water?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #3
Hi ammonia and nitrites 0 nitrate 5. Tank has been set up for about 5 years. water changes 25% every 2 weeks. Treatment was nox-ick.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #4
Just noticed I posted this in the wrong place. If a mod wants to move it to the correct place that would be great.
 

·
Registered
Joined
·
519 Posts
Just noticed I posted this in the wrong place. If a mod wants to move it to the correct place that would be great.
Pictures would help greatly also I recommend using reddit heres the link to the amazing community with great info about pretty much everything aquatic also: https://www.reddit.com/r/Aquariums. I recommend taking some photos of the Krib and whatever and giving some background info on your post or else you might possibly get asked a bunch of questions.
 
1 - 5 of 5 Posts
Top